Millumin 2 with Artnet Control


Wanting to see if anymore has a guide on how to get Artnet control for Millumin 2 from a Grandma 2 lighting console because when I go into interactive and go to Artnet it has a green dot next to it but it seems to have that all the time.

Also does anyone have a Grandma 2 fixture file for Millumin 2.

If anyone can help it would be great an I need to be able to do it this weekend.

(If not for Millumin 2 even Millumin 1 with Milluplug would be the next helpful thing)



  • Hello @LukeBoyd,

    Unless there is an issue with the network, Millumin is always able to create an Artnet node : so it's normal that it's green.
    Are you sure that your Grandma is sending Artnet to your computer ?

    Lastly, there is no fixture for Millumin : simply click on "Interactions" in the top-bar (or press CMD+M), then assign your Artnet signal to a function in Millumin. More info on this tutorial.

    Best. Philippe
  • edited May 2017
    I have been trying to get Millumin to see Art Net and it does not respond.
    I have tested to see if the computer is receiving Art Net through a third party app that confirms I am sending correct data.
    I have also tried to assign functions to layers and Millumin does not see the function.

    I have also tried to assign DMX function though the PRO Mk 2 and the computer sees the dongle but Millumin does not see the incoming DMX

    Thank you
  • Hello @Picassopro,

    What version of Artnet you're using ? Millumin supports Artnet V1 and V2, not V3.
    Also, be sure you selected the right network interface (wifi or ethernet) in the Device panel (press CMD+K, tab "DMX").

    Best. Philippe
  • In my humble opinion implementation of Artnet in Millumin V2 is not ok. I have made few tests:

    I have a GMA2 console with 512 dimmer channels patched on line 1. I've set output to Arnet and when I connect it to a Windows PC with Resolume it works as expected. When I map something in resolume and change channel on console - it works. That means that console is outputting artnet properly. 

    When I connect Mac PRO with millumin (with same cable that I've used to connect Windows machine) - Artnet also works but not as expected. 

    Millumin sees Artnet with interruptions. Few seconds ok - few seconds not ok. 

    I will do some more testing... Next thing I wan't to do is testing resolume on MAC. If resolume works ok - it will prove that implementation of Artnet in Millumin V2 is wrong.
  • Same MAC, same MA2, same cables... when I start SAMSC Catalyst - it works as expected. 

    So.... Millumin and MA2 - not working.

  • Hello @sledzik1984,

    Are you running Millumin in trial mode ?
    When the trial expired, we limited how Millumin sends DMX signal : DMX is interrupted from time to time.
    I've to admit it's not obvious at all, so we'll add some info about this in the next update.

    We haven't notice a problem with Artnet during our tests, workshops or projects. A few questions :
    - What is your version of Millumin ? 2.18.m ?
    - What is your version of macOS ? 10.12.6 ?
    - Did you try to use mobile application such as ArtnetControl or iVLD : what are the results ?
    - Could you send us a minimal project where the problem happens (just the .millumin file) ?

    Thank you for your answers point by point.
    Best. Philippe
  • Yes. It was trial... You sholud write all limitations of demo version :) 
  •  Hello @sledzik1984,

    Yes, next update will clearly show this limitation when the trial expired.
    The only other limitation is the white lines in output (also when the trial expired).

    Best. Philippe

Sign In or Register to comment.