Custom OSC message

Hi,
I'm trying to send this message via OSC to a Congo lighting console, basically in order to fire its 6th Cue.

/actionmacro GO PB,6

If I use the "test" function of an OSC data track, it works (sending both value 0 and 1, but it works ok, the Congo gets the Cue).
if I use the flag, unfortunately the message is changed to "/actionmacro 6" so it can't work.

and if I use a string data track, the address seems legit but it doesn't work either.

Any idea ?
Thanks   

Comments

  • edited February 29
    Hello @hyll,

    This is normal : the address of the OSC message should not contain spaces (see OSC specifications). Despite there is some tolerance in the data-track ...
    Anyway, you are confused between the OSC address and the OSC parameters. Indeed, in your example : "/actionmacro" is the address and "GO PB,6" is the parameter. Check this documentation for more info.

    In brief : type exactly  /actionmacro "GO PB,6"   for your OSC flag, and it should work.

    Best. Philippe

    PS : OSC is not a simple string, so it won't work with your lighting console (unless it converts stringto-OSC like Millumin does)
  • Thanks, yes indeed that's the right way to do it and it does work. ;)

    Correct me if I'm wrong, but I thought that on a timeline in OSC flag mode, this message would be sent only when the keyframe/flag is played.
    It does work that way when I manually play my timeline. 

    But my timeline is synchronised with MTC, and the message is sent anyway on each start on a random timecode. Any idea why ? 

  • Hello @hyll,

    Indeed, this is a special case, thank you for reporting it.
    A fix will come in next beta update (3.15.k). I sent you an intermediate version.

    Best. Philippe
  • thanks philippe
Sign In or Register to comment.