Auto-follow latency

edited September 2019 in MAIN
Is there a solution to the very small auto-follow delay? (M3 - but is also present in M1+2)

I have a show where I want the audio to continue seamlessly from one column to the other although it is divided in two audio files.
Audio one has 'auto-follow' enabled. no transitions. Audio two in the next column. no transitions. (Qlab does this perfectly)

I have tried with wav files and videos with audio embedded. the result is always the same - a small break before the next audio. (we are speaking about 100-200ms enough to be noticeable )
I have even tried launching the audio from Qlab  via millumin+autofollow+osc on the same mac.It produces the the same latency.

However if I manually go to the next cue/column the delay isn't there.

Any help will be very much appreciated.



  • Hello Soren,

    Could you send us a small project reproducing this issue (via email), please ?
    Thank you, we'll study it.

    Best. Philippe
  • Hello @SorenBcn,

    Thank you, we received your project.
    I understand your issue. Millumin doesn't treat the media like QLab : indeed Millumin starts media based on monitor's frequency, so when a column is launched, it's always just before rendering the next frame. There are pros and cons, but this is good for video rendering, less for audio rendering.
    In brief : if your media's duration doesn't match your monitor's frequency, this could lead to a small silence of audio. I hope I'm clear enough.

    Anyway, one solution would be to use a transition with a duration about a frame (16 or 20ms usually).
    Another one, is to render your audio as one file, and use the "auto-go program" new is latest beta (please look at the attached project).

    Let me know if you have a question.
    Best. Philippe
  • edited September 2019
    Thanks for the fast feedback and explanation Philippe 
     - when you write transition, do you mean column or layer transition? 
     Making a linear column transition of 0.15 seems to be the sweet spot for me. Less it doesn’t have effect for me. Layer transitions doesn’t do anything for me neither. 

    The auto-go option is a great feature that I am looking forward to use. I normally use an empty video for exactly that.

     Thanks a lot,
  • Hello @SorenBcn,

    I meant a column transition (and your media in "auto-follow" mode, will follow this transition).

    I guess the auto-go option is better in your case.

    Best. Philippe
Sign In or Register to comment.