Millumin on imac pro

Can I use millumin in the new iMac pro ?


  • Hello @abdel,

    Yes, for sure. We just ran a couple of tests yesterday, and we were able to run 4 x 4Kp30 displays (equivalent to 16 x 1080p30 outputs) while playing 2 x 4K movies. The system was working great.
    We hope to do more tests with more displays in the future.

    Best. Philippe

  • I will play 4x2k
    What adapters can I use
  • Hello @abdel,

    The Datapath FX4 is probably the best one.
    You can find more here. Or you can use the 4 x USB-C ports of your iMac Pro.

    Best. Philippe
  • I'm using a new iMac Pro with 3 1080 outputs using the USB-C ports and the apple HDMI dongles. I'm finding that ProRes playback get choppy at times. Files are playing from the internal SSD, but the playback seems to jump every so often. Any thoughts? 
  • Hello @SnowGloeb,

    This is a very good configuration, and you should not have issue running your 3x1080p60 project with it.
    A few questions :
    - What is the version of Millumin ? 3.11.k ?
    - What is the version of macOS ? macOS 10.14.2 ?
    - What is your codec ? ProRes-4444 ? ProRes-422 ?
    - If you display the FPS in Millumin (see "Output" menubar") : how the FPS is varying ? Is it stable at 60fps, then drops to 35fps for 10 or 20 seconds, andcome back to 60fps ?

    Thank you for your answers point by point.
    Best. Philippe
  • Thanks for the reply - 

    Mojave 10.14.2
    Millumin 3.11.k
    ProRes 422 (typical) or ProRes HQ
    - Still looking for a HAP codec and encoder that work with 10.14.2
    FPS is 60fps, then drops to 58 or 52 (on a paused output) and can drop to 35 or so then come back to 60 with looping files.
  • Hello @SnowGloeb,

    Your issue seems to be related to a bug we submitted to Apple : this affects a few configurations on macOS Mojave 10.14, and this doesn't affect only Millumin but also other softwares relying on GPU (Resolume for example).

    We provided a lot of info to Apple engineers, we chatted a bit with them, and now we're waiting for their reply.
    Hopefully this gonna be fixed soon.

    Could you come back to macOS 10.13.6 and let us know if the problem persists ?

    Best. Philippe

    PS : to encode many files in HAP, use AVF Batch Exporter.
  • Thanks - I'll try backing down to 10.13.6. I need to find an install for it as the computer came with Mojave installed. 

    Also, I've tried using AVF, but the program crashes upon export. 
  • Ok let us know the results.
  • Hi, I’m about to do thesame setup and would love to hear if there is any update!
  • edited June 2019

    This problem seems fixed in latest macOS (10.15 Catalina).
    now this macOS is in beta but looks stable.

    We can send you a DMG file to install macOS Catalina if you want to. At least to try this out.
    Please send us an email if so.

    Best. Philippe
  • That would be great thank you! Looking forward to trying it out! Do you have our email or should we email you directly?

  • Hello @whataweirdguy,

    Email our support (contact at millumin).

    Best. Philippe
  • Just a heads up to anyone with an iMac Pro, or even just newer macs in general. There is a T2 security chip bug that hasn't been resolved yet that affects audio input. The bug cuases drop-outs and other intermittent issues that can affect timecode input and midi inputs. The result is video playback that can stutter in an otherwise fine project in a machine that can handle the processing. 

    I've been working constantly with a audio engineer / technician for the past few weeks and we are yet to find a work around. I will post if we figure something out. 
  • edited July 2019
    Hello @whataweirdguy,

    We're not aware of such a bug, but there is a bug on macOS 10.14 Mojave with certain configurations, that looks like the one you describe about video.
    Last week, we sent you a DMG file to install macOS 10.15 Catalina : does the problem persists ?

    Best. Philippe

    PS : for info, the next Mojave update (10.14.6) should also fix this issue.
  • Hey I did get it and installed two days ago. Video side it seams to work great. An occasional stutter here and there but acceptable. Millumin is running at a steady 60fps. 

    Regarding the timecode, there is a significant audio issue that is present on all OS's on machines with the T2 chip. I've seen with midi timecode as well, watching the midi signal blip intermittently and enough to throw the whole thing into a stuttering mess. 

    I will be watching it stutter multiple times per second, and then the moment I unplug timecode (timecode freewheel is set to infinite), it gos perfectly smooth. However other times, without changing a single thing, i can get through an hour without noticing a stutter. 

  •  Hello @whataweirdguy,

    We try on :
    - a MacMini 2018 (thus with a T2 chip)
    - latest beta of macOS Mojave (10.14.6)
    - with an USB audio device to capture a LTC feed
    - with a 1080p60 movies displaying a line (so we could easily see if there are some hiccups)
    - this movie being control by the LTC feed (no freewheel)
    - no problem during our 5-minutes test : neither in movie playback, neither in timecode display
    - as stated in the article, we repeatably toggled the “Set date and time automatically” check box, but no problem appeared

    Could you confirm us that your have this "T2 chip" issue on latest macOS Mojave beta or on macOS Catalina ?
    Best. Philippe
  • edited June 2019
    To be honest 5 minutes is not enough time to see it. I've gone an hour without seeing it, then it pops up. Unless its some other issue in Millumin, I'm not sure what it could be. Timecode from different sources, different speeds (29.97, 30, DF/NDF), and different interfaces all seam to exhibit the issue. Playback without timecode seams to be acceptable. Muting timecode with freewheel stops stuttering during playback. 

    I'm running a 2018 iMac Pro, 16 core with the Vega 64 gpu. Three outputs, one 4k canvas going to a 4k projector, and two 1920x1200 projectors that are blended to one canvas. Two 3840x1492 prores 422 video files layered. Anti- aliasing settings have no affect on playback. HAP had constant stuttering. Playback FPS stays holds a steady 60fps, with the occasional drop to 58fps.

    Tried High Sierra, Mojave and Catalina. 
  • Hello @whataweirdguy,

    Since the bug should come from the "T2 chip" of such Mac, and it affects the audio capture : the timecode should have hiccups, right ?
    Could you check in Millumin's device-panel (CMD+K) that the timecode becomes red then green again, then red, ... ? It would confirm that the audio capture has a problem with "T2 chip" computers (and explain why setting the freewheel to 1 second fixes the issue).

    Thank you. Philippe
Sign In or Register to comment.