Check for update error [SOLVED]

edited February 2016 in MAIN
Hi all !
I keep running onto the Update error message ("An error
occurred in retrieving update information. Please try again later."), on
both Millumin and Millumin 2 (I believe it's a more general Mac
security issue, but can't find what setting I need to change in order to
solve it...)
Any help would be warmly welcome !

Thanks in advance


  • Hello @eMTv,

    In rare occasions, our servers may be down for maintenance by our host. It's rare but it can happen.
    We checked and everything is fine now.

    Let us know if the problem persists.
    Best. Philippe
  • Hi Philippe,

    it's not linked to your servers being down, as I was able to check for update on another computer.. More a matter of Mac OS setting, but can't find out... However I know now that I can still find the latest version to download on My Account page.

    Thanks anyway !
  • Hello @eMTv,

    We checked frequently in the latest day, and everything is fine.
    And yes, you can download the latest version from your account (just saying for the record for other users).

    Best. Philippe
  • I would like to re-open this issue. I am getting it frequently and I know it is file permissions related but have not quite nailed it down yet.
  • Hello @martyberg,

    Could you give us as much information as you can, such as :
    - your version of Millumin
    - the type of network you're using : Wifi, Ethernet, via proxy, ...
    - what is exactly the error your got, and how many times per day you have it
    - does the error appears automatically, or only after hitting the button "Check for updates ..."

    Thank you. Philippe
  • Millumin v.2.16h
    Wifi network
    Error: "An error occurred in retrieving update information. Please try again later."
    Error happens every time I hit 'check' or 'Check for updates'
    Happens on one computer but not on the other (at the same time)

  • Can you tell me what system folders the program needs to access to do the update check? I'm thinking that's where the permission problem is.
  • Hello @martyberg,

    We're still trying to reproduce your issue, but we couldn't.
    The only file that needs write permission, is

    Are your 2 computers (the one failing and the one ok) on the same network ? What are the differences between them ?

    Best. Philippe
  • Yes. Same network, same os, pretty much identical. One is Mac Pro on MacBook Pro. I think the problem started after creating new user account but all permissions seem to be correct and I have trashed and re-downloaded the app and still no go.
  • One thing that is strange about the issue - the error comes up immediately. Doesn't appear to be even attempting to make the connection.
  • Hello @martyberg,

    This is strange.
    Are you sure you don't have a firewall blocking the connection with Millumin's update server ?
    Can you display the changelog (from menubar, Help -> Read changelogs ...) ?

    Best. Philippe
  • For the record : Marty's problem has been solved with recent updates.
  • Looks like the issue is back with the latest version :/

    - updated Millumin on MacBook Pro and copied the latest version over to MacPro
    - when I hit 'check' I get instant 'Update Error' on MacPro
    - MacBook Pro has no issue checking for updates at exactly the same time

    Both running latest OS (Sierra) and otherwise appear to run fine.
  • Hello @martyberg,

    I sent you a special version via email, so we could learn more about your issue.
    Let us know the results.

    Best. Philippe
  • I am having this exact same issue! I really want to update to the beta version for arduino support. But I get the Update Error! message. I've tried disabling the firewall and the permissions are read & write

    Im running Millumin 2.17.p
    Mac 10.12.4
    macbook pro 13" 2016
  • Hello @Arran22,

    Can you read the changelog ? (click "Help" then "Read changelog" from menubar)

    Best. Philippe
  • Yes I can look at the changelog
  • I really only want the beta version so I can use an arduino, is there any way you could just send me a copy of it ?
  • Hello @Arran22,

    We sent you a download link to install the beta manually.
    Please let us know if the problem persists.

    Best. Philippe
  • Hello @Arran22,

    Ok thank you for your info. We fixed the issue in the update system.
    It was a very rare case.

    Best. Philippe
Sign In or Register to comment.