Projector does not work as soon as I plug in my Kinect

edited January 15 in MAIN
Hey guys,

I have a problem that really kinda sucks. So here's my setup:
I am currently working with a trial version of Millumin2 on a MacBook Pro 15" (mid 2012) with OSX El Capitan 10.11.1 installed. My projector is an Acer P1173. It is connected to my MacBook via an HDMI --> Thunderbolt cable. With Millumin2, this setup works perfectly fine. I am planning to make an interactive projection mapping project. So I got myself a Kinect (the old one, version 1). I installed the dependencies as Millumin suggested and played around with the Kinect mask a little - while the projector was unplugged. Worked fine as well. So I wanted to see it "in action" and plugged in my projector. Unfortunately that was the moment when things didn't work out so well anymore. The output of my projector did not appear - all I could see was a text that said that the signal was being processed but except for that nothing happened. The moment I unplugged my Kinect, the projector output returned. As soon as I plugged in my Kinect again, the output was gone once again... So apparently I cannot use my Kinect and my projector simultaneously which totally sucks. :-(
I think it is definitely not a Millumin problem because even if I have Millumin closed, the projector output does not show up as long as the Kinect is connected to my MacBook. I started several solution approaches by restarting everything and plugging in the Kinect first and then the projector. But nothing of that has worked so far.
My roomie has Windows 10 installed as a partition on his MacBook so we thought we'll try to see if it is a software/driver problem since the Kinect is a Microsoft device. Surprisingly, the projector output worked fine while the Kinect was plugged in, but this time the Kinect didn't (the green lamp wasn't on). This might be because we didn't have any drivers installed for the Kinect on Windows, but we thought the Kinect's lamp should at least be on, right?
Well, now I wonder if it might be a hardware problem or a software problem. Could it have something to do with my MacBook's graphics card? Are there any projection mapping experts hanging out here who might have an idea what is wrong? Maybe the solution is really simple. I have a pretty cheap HDMI to Thunderbolt/mini displayport cable which was like 10 Euro on Amazon. Since the projector output returns a message that the signal is being processed, do you think it might have to do sth with that? I'd prefer not to invest in a super expensive cable yet, not as long as I don't know what is causing these issues.
Thank you guys in advance for any help!

Comments

  • Hello @nika,

    Could you try to make your setup by connecting your projector with a hdmi-hdmi cable ?
    Does your setup work on another mac ?
    Does it work by using another projector ?
    Did you try to plug your kinect on another usb plug ?

    Sincerely your,
    Nicolas
  • Hi Nicolas, 

    thanks for your reply. Unfortunately my MacBook does not have an HDMI port, it only has MiniDisplay Port/Thunderbolt. 
    The same problem occurs when I connect the Kinect and the projector to my roomie's Macbook which is, I think, from 2010.
    I do not have access to another projector, but maybe I can find a way to test it somewhere. 
    I tested the Kincet on both of my USB 3.0 ports and - as long as the projector is unplugged - the Kinect's function in Millumin works perfectly. The problem only occurs when both the Kinect and the projector are connected at the same time. Sometimes the projector's output shows up for a second and then disappears again. 
  • Hi @nika,

    Are you using an USB extension cable to plug your Kinect ?
    What is the model of your kinect ?

    For example, the attached file model is 1473 .

    Sincerely your,
    Nicolas
    kinect model.jpg
    2701 x 2394 - 2M
  • Hi Nicolas,

    thanks again for your help. I did not find a specific solution for my problem, however, I found a workaround by replacing the HDMI to Thunderbolt cable by a VGA to Thunderbolt cable. Since my projector is only capable of a 800x600 resolution, this is okay. It works perfectly now. I'm not sure what's the deal with the HDMI thing, though. But anyways, I can do an interactive projection mapping now! :) 

    Nika
  • edited January 17
    Hi @nika

    Thank you for let us know your workaround. If we find a better workaround, we let you know. But I think it is more a hardware problem than a software one.

    Good luck for your show,
    Nicolas
  • Hi Nicolas,

    thank you! I know it is not a MIllumin problem, but I thought maybe there are other people out there who were confronted with the same problem while trying to work something out with Millumin. :)

    Nika
Sign In or Register to comment.