Vertical edge-blending method

edited May 2016 in MAIN
This is deprecated : Millumin V2 supports now vertical soft-edge.


Some of you asked us about vertical soft-edge. As now, Millumin provides direct horizontal soft-edge, but it is also possible to do a vertical one.
The principle is simple : using 2 instances of Millumin with rotated images.
Of course, we are working on a more ergonomic method.

Here is a step-by-step example for 2 projectors with a final resolution of 1920x2160 :
  1. Duplicate "" (CMD+D), so you could run 2 instances

  2. Plug the 2 projectors

  3. Rotate them by 90° in the System Preferences / Displays (you do not rotate them physically)

  4. Run the first instance of Millumin : it will manage the content and videomapping

  5. Set up the final output resolution as 1920x2160

  6. Toggle "Syphon Output" from the menubar

  7. Run the second instance of Millumin : it will manage the soft-edge

  8. Set up the final output resolution as 2160x1920

  9. Set up 2 screens in the "Multiscreen" tab, then assign them to your 2 projectors

  10. Show the test card

  11. Follow the soft-edge process as described in this tutorial

  12. Now your 2 projectors are blended vertically

  13. Get the first instance's result into the second one via Syphon

  14. Rotate the Syphon source by 90°

  15. Now you can go back to the first instance, and work directly on your content


  • Hi,Pillippe,
       I follow your tutorial step by step,but there is still a problem with this method.
    I plugged my projectors to a Matrox Dualhead ,my projector's  resolution is 1024X768, so after I rotate them by 90 degree,it was 1200X1600 ,I setup the first millumin output as 1200X1600,and click the syphon output.then run the second millumin. I can see millumin1 is in millumin2, I set output as 1600X1200,the problem is that the video on wall is not correct.It shows me two independent pictures,it's impossible for blend-edge.
    I don't know why this happened.
  • edited November 2013
    Hello @gary,

    It's not that easy to do vertical soft-edge with a DualHead as Mac OSX recognizes it as a very large display.

    I think you messed up with the resolution : you DualHead should be detected as a 2048x768 display (if your projector resolution is 1024x768).
    As you want vertical arrangement for your video projectors, the first instance of Millumin should have a resolution of 1024x1536 (this is your content resolution).
    Then, the best solution would be to define the resolution of the second instance as 2048x768 (do not rotate the video projectors). And do the soft-edge manually with the "Soft Crop" effect.

    Best. Philipe
  • Hi,@Millumin,

    Thanks for your respond. 
    Yes,My macbook detected that as 2048x768 before I rotate 90 degree.But everything goes wrong after I rotate it.
    before I did it, each of projector has half part of the video,after I rotated it,the resolution was changed to 1024X1280 by itself automatically. I will take some photos for you.
  • Hello @gary,

    Do not rotate your DualHead in System Preferences : it won't help you.
    Please use the method described in my previous message, or wait for native vertical soft-edge support.

    Best. Philippe
  • Hi,Philipee,

    However,Thank you all the same, maybe I have to wait for native vertical function. :)

    Best Regards.
  • Hi Philippe,

    I use imac with i5 processor and os x mavericks.
    I can't find a function in system preferences where i can rotate my monitors 90 degree.

    Is it possible to help me?

  • Hello @Digimoto,

    Maybe you could maintain the ALT key : it makes appear more options on System Preferences. If the "rotation" parameter doesn't appear, it's because your monitor doesn't support it.
    In this case, I'm sorry, but you'd have to wait until we finished the vertical softedge feature.

    Best. Philippe
Sign In or Register to comment.