OSC media speed control

I am following the Millumin OSC documentation on GitHub, and I am not getting the expected results for media speed control. I have already confirmed OSC control is working using the following method of access:

/LAYER_NAME/media/time [value]

When I fire that off, the media at the active column on the target layer indeed moves its playhead to the specified time. However, when I switch the reserved word "time" for "speed", I do not get a successful result:

/LAYER_NAME/media/speed [value]

I am currently running test using version 3.11.r. The documentation states that the specified speed value needs to be of 0-1 floating point range (eg. 0.5 = 50% speed). Just to make sure that was not a documentation error, I have tried both 0-1 and 0-100 ranges. All efforts to specify speed using the above method of access has resulted in no apparent effect within Millumin. If anyone has any thoughts and/or ideas, please let me know.


  • I just tried with OSCTestApp here, and it's working as expected.
    Could you use OSCTestApp and let me know if you still have the issue ?

    Best. Philippe
  • Sorry for delay in response. I downloaded OSCTestApp and used it. I still did not have success with the "speed" command. Here is what I did and the results:

    1. Set "OSC address" field to "/LAYER_NAME/media/time" and set the "Send Float" field to 15.5.
    2. Pressed enter and the media in the active column of that layer indeed cued to 15.5 seconds of the .mov file.
    3. Set "OSC address" field to "/LAYER_NAME/media/speed" and set the "Send Float" field to 0.5.
    4. Pressed enter and the media continued to play at 100% speed instead of 50% speed

    Should I have gotten a result of 50% playback speed? Or am I misunderstanding the intention of the OSC documentation on how the "speed" command is intended to work?
  • Ok, I figured it out. It turns out the cell I was targeting contained a timeline, not a MOV file. I had wrapped the MOV file within a timeline for different reasons and had completely forgotten I had done that. It is odd though - I was able to control the playhead of the timeline with the "time" command, but for whatever reason, "speed" is not an option. I would suspect that is a feature that could potentially be added in the future? Since timelines and video media have the same time base characteristics?

  • Indeed, timeline have a playhead but no "speed" property.
    Feel free to submit an idea on Uservoice, so we could see if other people are interested.

    Best. Philippe
Sign In or Register to comment.