Video Playback speed

Hi!
I am trying to find a way to use a midi controller (Akai APC 40) to control the playback speed of video -universally. I know you can regulate each clip, but then each clip in each column in each layer needs to be separately programmed.

Also, even in the timeline you can't regulate the speed of playback. Would be a great feature for following live performances - if it doesn't already exist hidden somewhere.

Thanks,

David

Comments

  • Hello @Chocron,

    I am sorry but there isn't any function like this hidden in the software.
    Anyway, the idea is interesting so you can note it in the uservoice, so we can keep track of it.

    Sincerely your,
    Nicolas
  • edited August 31
    Hello @Chocron,

    To complete my answer, you can do something like that by using Chataigne. You can ask Chataigne to send multiple OSC order when it receive on osc order. The project will look something like this :
    image

    You can find the example in the attached file.
    If you need to stop all your media, you can create an interaction on the master pause. See :
    image

    Sincerely your,
    Nicolas
    zip
    zip
    control speed via MIDI.noisette.zip
    1K
    pause.png
    566 x 348 - 19K
    chataigne.png
    1804 x 1022 - 241K
  • Hi Nicolas,
    Thanks for your swift reply and Chataigne solution. I have not worked with Chataigne and am not much of a programmer. As well there is absolutely no documentation for connecting Millumin to Chataigne - or my midi controller (APC 40) to Chataigne. I would very much like to test this solution, so if you have time to send me  some simple instructions for setting this up (both in Millumin and Chataigne) it would be appreciated greatly.

    And by the way, the file you made was in  Chat. 1.3.2 - so the interface seems to look very different now. I just downloaded the old version so I could recogninze your screen shots.

    Best regards and thanks from,

    David
  • Hello @Chocron,

    You can find in the attached file an updated project for the last version of Chataigne. I encourage you to look at it to better understand how to do your own project. If you need more help, you can find all the Chataigne documentation her.

    Sincerely your,
    Nicolas

    zip
    zip
    control speed via MIDI (1).noisette.zip
    2K
  • Hi Nicolas (or anyone else who understands this)

    I have tried to use this document. I have programmed a MIDI CC#9 (fader) input to OSC to Millumin output. Input and output seem to register both in Chataigne and Millumin. So far so good. I trigger a layer with video, move the fader. Nothing happens. No speed difference. OSC is turned on in Millumin.

    You ask me to read the Chataigne documentation about Millumin, but if you check yourself there is none. Not yet at least. I feel like I am very close, but something is not right.

    Also, this is only for selected layer and not whole project, correct. Well, that's better than nothing, if I get it to work.

    Please send advice if you can. Appreciate it.

    Best,

    David

  • Well, I have managed to hook up the OSC in the interactive window (finally saw the tutorial) and some of the tracks are responding, but not all. Not too sure exactly what should be in the address and what should be left out in Millumin. I typed in /1/media speed and that seems to work for the first rows of each canvas. I can not get the speed above 100% no matter how I configure. Any tips are appreciated. I will continue to experiment.
  • Hello @Chocron,

    There is not a specific documentation about Millumin in Chataigne's documentation because there is no need. Chataigne just receive and send OSC/Midi order, it doesn't care about which software it communicates with.

    If you need specific documentation for Millumin, you can find a tutorial here about how to create and manage interaction in Millumin.
    If you want to control Millumin directly with OSC order, without creating any interaction, you can find here the list of all compatible OSC orders.

    Anyway, I can't success to understand exactly what is your problem. Can you re-explain me it in detail, if you can't success to find an answer in the documentation ?

    Sincerely your,
    Nicolas
  • Hello Nicolas,

    I have it all working except that no matter what I try I can only go from 100% to 0% speed, but not faster. I have tried playing with the parameters in Chataigne and in Millumin but for some reason I cannot make the video speed up. 

    And also speed changes do not affect timelines in the dashboard. But I am happy it is almost working properly : )

    Thanks!

    David
  • Hello @Chocron,

    If you have create an usual interaction, you can edit the range of values on which you want to interact. In the attached picture, I made a switch interaction that change the speed between 100% and 200%.
    If you use OSC, you can do it more easily by directly sending the speed you want. More info here.

    For many technical reasons, you cannot change the speed of a timeline in Millumin.

    Did that solve your problem ?

    Sincerely your,
    Nicolas

    A.png
    510 x 348 - 25K
  • Hi again,

    I have tried this (and also in the sent message from Chataigne) and it did not work. I don't know why.

    I will continue to experiment. Thanks,

    David
  • Hello @Chocron,

    Did you finally fix your problem ?

    Sincerely your,
    Nicolas

  • Hi !
    I've done some test in the bêta version of Millumin 3 to check video playback speed control using OSC from a live sensor. 

    After trying Photo Jpeg, HAP, HAPQ and ProRes422 codec encoding, it seems while the sensor value is changing the video playback is not fluid and the sound is freezing before to continue at the last given speed (even if I reduce the flow of the incoming data).

    I've made a prototype in Max/Jitter that works with the deprecated qt engine and photo jpeg codec but Millumin provides many features I don't want to develop in Max :)

    All the video I used for those tests are encoded with the AVF Batch Converter software.

    Any idea of what could be wrong ?

    Best regards,
    Theod


  • Hello @theod,

    Does your video have audio ? Try without audio, the playback will be smooth when changing the speed.
    This is a technical limitation when decoding movie with Apple 64-bits framework (not like QTKit 32-bit framework).

    In Millumin V3 beta, you can use choose to manage the audio independently, so it don't have this problem : open the audio-panel (CMD+U), then assign the audio to a specific output.

    Best. Philippe
Sign In or Register to comment.