Control a projector with serial String Track

Hi everybody ! happy new year

I am wondering if someone can help me with a problem i have.
I need to control parameters of a a projector ( Christie roadster s+20K ) via millumin.
What i do for now is using string command via rj45.
In the interaction panel i put the IP of my projector and the port.
In the dashboard a data track in string mode and in the command i put (SHUO)

Nothing happened when i use the test button

Then i tried to put (SHU[INT_VALUE]) and in the current value line put 1 or 0 ( open or close position of the shutter )

I think i have a bad understanding of something but i dont know if it come from millumin or of the control of the Christie.
Maybe string command is not the answer and there is other way to communicate to the projector via millumin.
I thought the Christie can understand Artnet...

Thank you for your help and time.

Love

Comments

  • Hello @dada,

    I'm not 100% sure but Christie uses TCP and not UDP protocol.
    What is your mode in Device-panel/Strings ? TCP or UDP ?

    Alternatively, could you open a terminal, and type : echo "(shu1)" | nc -w 0 192.168.0.8 3002
    This is sending a string to your projector.

    Best. Philippe
  • I ve tried the command line in the terminal... and it worked.... sometimes.... the shutter open and then close instantanantly, i don t understand why but i guess it is a good news because something happen.
    In millumin i tried both udp and tcp but i think the christie work in tcp even if i have found nothing in the documentation about it.
    Thank you
    David
  • Hello @dada,

    The terminal command I gave you, is doing the same as sending a TCP string with Millumin.
    In Millumin, be sure to type (wiythout the quotes) exactly the string "(shu0)" or (shu1)" but not "(SHUO)".

    Did you contact Christie's support about your shutter opening and closing suddently ? What are they saying ?

    Best. Philippe
  • RE,
    It still didnt work, in the terminal sometimes, in millumin never.
    In the monitor i can t see anything going out.
    For now i am gonna use the remote with a wire.
    I continue to investigate to understand why it doesnt work.
    Thanks for your time.

  • Hello @dada,

    Which "monitor" are you talking about ? The one of Millumin (displaying the messages that go in or out) ?
    What Christie's support is saying about the command working sometimes and not always ?

    Best. Philippe

  • Re,
    i was talking about the In/Out monitoring in Millumin that didnt show any messages going out from millumin via the string command.
    I didnt contact the Christie support.
    Finally i control the shutter via artnet, it was pretty easy to configure with millumin. To reach the universe 5 i had to put @6 in Millumin because the 0 doesnt exist in artnet universe btw.
    Thank you for your help.

  • Hello @dada,

    If the monitor doesn't show that a string-message is going out from Millumin, it's likely there is a problem in your setup.
    For example : the port could be busy, so Millumin cannot use it (because another application is using this port).

    Best. Philippe

    PS : for info, Arnet universes in Millumin go from 1 to 256 (not 0 to 255) and DMX channels go from 1 to 512 (not 0 to 511)
  • Hi Dada, 

    i would really like to do the same thing: control the shutter from Millumin. 
    I now have Millumin v3 and a projector Christie D20WU-HS. I am wondering where did you get the info of witch universe to use to control the shutter? 

    Thank you!
  • Hello @domhawry,

    If your projector can be controlled via DMX, you can use a data-track sending the according DMX signal (see the projector's documentation to know which one controls the shutter).

    If your projector can be controlled via "strings", also do it via a data-track, but send a "string" (instead of DMX). Do not forget to configure accordingly the "string" server (IP and port of your projector).
    In Millumin V3, we added "string" templates for the protocol PJlink.

    On a general topic, more info about data-track on this tutorial.

    Best. Philippe
  • Thank you, i manage to make it work. 
    We had to put in the command line AND in the "current value" (SHUT 1) and 1. ( (SHUT 0) and 0 for shutter open).
    If not it was flickering because the log was receiving an 1 and a 0... so we also have to double the string track in our dashboard... 

    Also we had to check the "always trigger" box. 

    I'm happy to have made it work! 

    Attached, a screen capture of my settings if it can help someone.
    Merci.

    Capture d’écran 2018-10-16 à 15.59.31.png
    1920 x 1080 - 260K
  • Hello @domhawry,

    You should rather use the string "(SHU [INT_VALUE])", so the "INT_VALUE" is replaced by the value of the data-track (0 or 1). Click on the small triangle next to the field "command" to have autocompletion.
    That way, you'll only have one data-track.

    Best. Philippe
  • Hello!

    Yes finally i had to do that but my problem is that my shutter is "flashing" because in the logs i see i sent (SHUT 1) and (SHUT 0) but it finishes by the right command... I'll do some tests when i have more time and keep you updated. 
    Thank you. 
  • Hello I'm trying to do the same with a Panasonic RZ970, it seems that the old Projector MIDI Remote is no more available…
    Is there a way to control directly the shutter via Millumin;
    PS to MilluTeam you can answer me in french
  • edited October 25
    Hello @R1Erwan,

    I'll answer in english so everyone can understand.

    The projector you are using supports PJ-link.

    From what I read in the manual, you might be able to use the shutter using the command :
    "AVMT [INT_VALUE]" or "%1AVMT 3[INT_VALUE]\r"
    and pass 30 or 31 as parameter in the datatrack.

    Hope this helps

    Regards

    --
    Antoine M*


  • Thanx it woks

Sign In or Register to comment.