Bug: Hide menubar and mouse when in FullScreen

edited December 2012 in MAIN
Hi. There's an issue when you enter fullscreen on your main screen. OSX menubar and mouse stays visible!
Please add this to the list of bugs ;-)



  • edited December 2012
    Hello @CosmicZ,

    This is not a bug. This is the expected behavior when you run fullscreen on your main screen.
    Some users don't remember the shortcut to exit fullscreen (CMD+F), and they are blocked in fullscreen. If the menubar is present, they can easily exit fullscreen.

    Do you need to run Millumin fullscreen on your main screen ? Or is it just for test purposes ?
    I could add an option to hide the menubar, but I need first to be sure that it will be useful.

    Thank you. Philippe
  • In this case Millumin is used as a syphon-switchboard controlled from Processing and Max over OSC. It's an installation in a museum, and I don't want to add an additional service-screen to it.

    I can see several situations where it would be nice to have this feature added.

    If you don't want to clutter your interface with to many options another way would be to enable/disable 'features' like this from the terminal.

    Thank you for the fast feedback!
  • Hello @CosmicZ,

    Ok, I added an option in the Preferences to do so.
    It will be available in the next update.

    Best. Philippe.
Sign In or Register to comment.