Best Codec millunode on Windows.

running a 12x projection blend around 19k pixels wide.. Thought I’d try millunode on windows to take advantage of 2x quadro P4000s framelocked via SLI (using 5 displayports @ 4096x1080) All is good my only issue is on windows the file stutters at the loop point. Mac no issues (it’s actually a hackintosh so on the Mac boot exact same hardware reading the same file from the same nvme, minus SLI support) I’ve tried the orig PR422LT .mov as well as HAP optimized .mov

any thoughts on what might be the issue?


  • Hello @seanradio,

    Thank you for your feedback.

    This may be an issue, yes. Sorry. We opened a ticket and we will come back to you as soon as possible.

    Thank you for your patience. Philippe

  • I appreciate it. It very well could be a windows optimization issue not specific to millunode. I know datatron watchout has a whole “windows optimization guide” for using windows for media playback with their media server software. Could possibly be related.

  • Just FYI.

    Tried this on a different windows machine and had the same issue. Slight hiccup at the loop point when looping a .mov (6480 × 1080 movie resolution). Hopefully this info helps the debug process.


  • Hello @seanradio ,

    We have done some improvements in movie decoding and fluidity. They should be available in next MilluNode release.

    Thanks again for your patience,


  • edited July 2022

    hi Elise

    Thanks for the update. I look forward to testing it!


  • Hello @seanradio,

    Please update to latest MilluNode version (0.34) and let us know if the problem persist.

    Thank you. Philippe

  • Hi Philippe,

    yes it is still happening

  • Hello @seanradio ,

    Can you tell us the codec and resolution of the movies which with you have this problem ?

    Also can you tell us the configuration of your computer (OS, GPU, CPU) ?

    So we can run more accurate tests to solve your problem.

    Sincerely your,


  • Millunode on windows 10,

    Movie File res: 6480x1080 (attempted codecs HAP, PR_422, PR_422LT)

    Windows computer 1 (which also is a Hackintosh macOs 10.13 which plays the file correctly using Millumin v3) :

    OS: Windows 10 Pro. Version: 21H2. Build: 19044.1889

    GPUs tried: single Quadro P4000, dual Quadro P4000 in SLI, Quadro P2000

    CPU: Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz

    RAM: 64.0 GB

    HD: Samsung M.2 970 Pro (x 3)

    I have another windows 10 Pro machine (that is also a Hackintosh) which I believe is an intel 8th gen.

    same results, fine in Millumin v3 on macOS 10.13, glitches on Windows.

    I have 2 other Windows machines that are running Windows 10 LTSC as Watchout servers with Quadro P4000s. I have not yet tried these. I also have a GTX 970 and a RTX 2080 super that are in other machines that I could eventually pull to try if needed, they are just not easy to get to at the moment, but I can do if you think it will help.

    Also, if it's possible for you to compile a macOs version of Millunode that will run on 10.13 High Sierra, I'd be happy to try that on the Hackintosh side of the windows machines to help narrow the issue down. I emailed yesterday with a cell phone video of the issue.


  • Hello @seanradio ,

    Thank you for all your feedback. We will investigate this issue and let you know when it is fixed in a future version.

    Sincerely your,


Sign In or Register to comment.