Audio panel

edited December 2013 in MAIN
Hi Philippe,

As said in my first post in a thread about the Iris chipsets, I'm currently testing Millumin for live touring with a band that got a pretty ambitious scenography consisting of 3 screens with back projections (3x 1280x720).

I ran out of trial but can manage to continue my tests with the watermark.
Anyway, the whole software is a giant piece of magic!

... But, I have one problem regarding the audio panel.

I have 3 layers of media (one for each screen).
In the "first" layer are medias for the left screen and each QT file contains a stereo audio track (the sequences of our music/show that are sent to the PA).
The "second" layer are medias for the center screen and each QT file contains a mono audio track (the metronome for the drummer that is sent to headphones).
The "third" layer are medias for the right screen and each QT file contains a mono audio track (the metronome for the rest of the band that is sent to headphones).

The problem is that the audio panel of each layer/slot don't allow me to choose the audio interface I'd like to use (Metric Halo 2882) even if it is connected and recognized by the Mac (and visible in the Audio MIDI Setup).
The only option available is "Default Output" so I can't route any of my audio to the desired outputs.

Is it an actual bug? The Ableton Live tutorial shows a functional panel though...
Is it a limitation that came with my trial period running out?

That feature is the only missing for me to convince the band to buy your software.

Bonus question: will audio multi channels QT ever be supported?

Thanks in advance for your time and help.
Best regards,



  • Hello @lopoic,

    Some drivers for audio cards are 32-bits only. Please check in the Millumin's Preferences if you're on 64-bits mode.
    If so, use the 32-bits mode : your audio card output should appears.

    By the way, Millumin supports multi-channels QT movies.

    Best. Philippe
  • Thanks!

    Indeed, the problem is solved while running in 32-bit mode.
    But, on my 3 years old MBP, the performance drop down to 15-16fps instead of 24-25fps.
    What's the best video format to use in 32-bit mode?!

    The situation is really strange as my interface driver is actually 64-bit.

    So, I did the test running Millumin in 64-bit mode on a 2012 Mac Mini...
    While keeping the Audio MIDI devices "blank" (integrated audio interfaces only), I created 2 aggregate devices and named them... Millumin never proposed any of the aggregated devices in the audio panel list and the only available option remained "Default Output".

    Can you confirm that behaviour?

  • Hello @lopoic,

    Yes, the Apple's CoreAudio functions used by Millumin doesn't recognize aggregated-devices in 64-bits mode. In 32-bits, they do. This is strange.
    We're working on a solution, but we cannot give you a date yet. Sorry.

    If you want to optimize the performance in 32-bits, you can click on the "Optimize" button (top-left corner) : Millumin will propose you recommandations and convert automatically files for you (Hap codec for 32-bits mode).

    Best. Philippe
  • The only recommendations I get are:
    - Turn 64-bit mode on as I'm using Mavericks > I wish
    - My frame rate is too low (25fps) > It's a technical choice

    I'll wait patiently for your fix on the 64-bit audio issue.

    Best regards,

  • Please do not change the framerate : it is synchronized to the display refresh anyway (usually 60 hz or 50 hz).
    Depending on this value, Millumin skips or doesn't skip frames.

    (by the way, do not forget to restart Millumin if you switch on/off the 64-bits mode, as suggested in the interface)
Sign In or Register to comment.