OSC Command for Cues go to 10/20/30


what is the OSC Command for go to 10/20/30?

Thank you :-)


  • I don't know if this is the official method, but I set up an OSC interaction.

    With your cues open, you can open the interaction window, click on the cue (say Goto - 30) then click the "+" on the interactions and select "OSC". On the right, change "/test" to what ever you want the OSC command to be (I use /goto30). Then send the OSC command "/goto30" (or what every you chose)

    Hope that helps.

  • Thank you Michael ! It works.

  • Hello Michael,

    I am on Millumin 4 /companion 2.4.2 (stream deck XL) and I just don't seem to be able to make it work. Tried many variations as well according to other references on the web without success.

    If you also happen to know how to change the countdown of the clips in mm:ss, that would be awesome.

    Any help is appreciated.

    Thank you

    screenshots attached

  • Hello,

    The first parameter on OSC address is number "0".

    I think it's the mistake.

    Best !


  • #Manu44 ... you solved it! Thank You

  • Hey all,

    I'm having a similar issue to what @mixedbyalex mentioned, although I believe it is slightly different, and all of your help on this thread has been great. So thanks for taking the time to respond.

    Here's my problem though-

    I am using companion with v4 Millumen. The GoTo cues once created are firing correctly if I fire them manually from the cue list. The OSC string is being sent correctly, and is being acknowledged by Millumen as the correct string.

    However, even though I have connected the OSC commands to the Cues through the Interactive Learning window, the cues simply will not fire. In fact any of the OSC commands, while they are coming in properly into the system will not fire any cues I create once they are mapped to the interactions. (i.e. A start cue for a column with the /goto-30 string, etc.)

    What am I missing, or did something break, or change between v3 and v4 that I need to be taking into account?

    Here are some screenshots to help understand what I'm saying.

    Thank in advance for any and all feedback.

  • Hi @dude,

    I think it's the same mistake because you use parameter number 1 instead number 0.

    And be careful because in your OSC message, the "1" is a string and not a number. Millumin don't like string for cue.

    But to trigger Goto-30, you don't need any parameter on your OSC message, just send OSC message : /goto-30 and normally it's works !

    (sorry for my english !)

    Best !


  • Hello @dude

    As stated in Millumin's monitor, you send a OSC message with a string parameter ('1'). Create a button with action OSC / Send message without arguments and you will be fine.

    By the way, the latest beta has direct OSC messages to control time (/action/goToTime), so you do not need to create all the interactions any more.

    Best. Philippe

  • Hey @Millumin,

    I will check out the Beta most certainly.

    What you stated with regards to the OSC message and the string parameter validates that I was setting things up the way they should be. However, what I was expecting should have been an interaction fired correctly, but it is not. It just simply is not functioning the way it should be inside Millumen.

    Maybe a bug?

    Also, I have found no difference in the Millumen logs between the OSC command of "Send message without aurguments" or "Send string" except the value/parameter being sent along with the command. It seems that this is irrelevant. Please correct me on this if I am wrong, and do tell me what the parameter is that needs to be sent.

    I think though in my troubleshooting over here, for some reason Millumen simply is not taking the OSC command, and firing the cue that should be triggered, and which was made in the interactions once that command is sent to Millumen.

    [Compaion sending OSC command -> Millumen acknowledges command sent in logs -> Command is linked to cue, but not triggering cue as it should]

    To give a little more detail, here are a couple of screen shots to help you understand what I can see, and what I cannot seem to get to work.

    #1- OSC-Send string command from Companion

    This works...at least with Millumen seeing the command, but not firing the cue tied to it. (Companion command= OSC-Millumin-Send string)-

    #2- OSC-Send message without arguments command from Companion

    This works as well at least with Millumen seeing the command, but not firing the cue tied to it either. (Companion command= OSC-Millumen-Send message without arguments)

    @Millumin thank you so much for responding to this thread.

    If there is an issue where you see in these screen shots that I am missing some parameter, or something that needs to be inserted into the path, etc., I would be grateful to learn what I am doing wrong.

    Otherwise, I think there is something broken where the OSC commands being acknowledged as coming into the Millumen machine simply are not connecting to the cues properly, even though they're being setup the way they should in the GUI.

    Thanks in advance for the help.

  • Hi @dude

    I try with chataigne to send exactly the same OSC message without argument and it doesn't work when you set, in millumin, number "1" in parameter setup. Try with 0.



  • Hey @Manu44,

    Thanks so much for the response, and my apologies for the prolonged delay.

    You helped solve something for me, but it wasn't quite as simple as changing the OSC Input to 1 for me. Thank you for pointing me in the right direction! That helped break the mental log jam.

    Pay it forward section-

    So when it comes to using Companion, in order to get the cuing and GoTo to function properly, you must use the "OSC-Millumin- MAIN: Send message without arguments" command." The "OSC-Millumin- MAIN: Send string" will not provide the results you're looking for. Even though the string is being recognized in the log by Millumin, it's just not fuctioning after that point, even if you link up interactions with cues.

    If you have everything linked properly on both Companion's and Millumin's side, the "OSC-Millumin- MAIN: Send message without arguments" command." I've tried this now repeatedly, and built both sides from the very beginning and it works. I DID take @Manu44 's suggestion and make sure that the parametier on the OSC Input was set to 0. I think that was the final key that was missing.

    Use those specifics to get GoTo cues to work, and you should be good to go.

    Thank you @Millumin, @mixedbyalex, and @Manu44 along with everyone else on this thread for the help!

Sign In or Register to comment.