ISF Shader not working Millumin 4 MacOS Monterey

edited January 22 in MAIN

I am setting up a project that I have done before on Millumin V3. For this newest iteration I am using a new M1 Macbook Pro (16inch 2021) MacOS Monterey 12.0.1

Millumin 4.12.d

A shader that I used in the V3 project is no longer working in V4. When the shader is enabled, no image is displayed. When it is disabled, the image comes back. I opened the shader in ISFEditor and the shader is working fine.

I'm not sure if this is a M1 or a Millumin V4 issue. Thank you!


  • Update:

    I tried the project in Millumin 4 on an older Macbook and had the same issue, so it does not seem to be a problem with the M1 Macbook.

  • Hello @ameliamayscott,

    Millumin V4 is using Metal, the successor of OpenGL on Macintosh computers. Long story short, this is for the better (performances, future of macOS, ...).

    ISF shaders are initially programmed in OpenGL, but we worked on a Metal implementation, so it could have better performances. Millumin V4 is using this Metal implementation.

    While the majority of ISF works out-of-the-box in Millumin V4, you may have an issue with a few ones, so do not hesitate to send them to us. Indeed, this helps us to fix edge cases as well as showing ISF errors in a better way.

    In your case, you used a variable named level, which is also a special keyword in OpenGL/Metal language. Consequently, it was conflicting (OpenGL is bypassing such errors but this is not a good practice anyway). So the solution was simply to rename the variable level into zoom, and that's it :

    Best. Philippe

  • That fixed the issue.

    Merci beaucoup!

Sign In or Register to comment.