Glypheo NDI output on Mac M1


I have a macbook air M1 ( big sur OS ) running glypheo connected to a millumin on a local network and i cant see the ndi output of my panel.

Did someone experienced that ?

Is it due to the M1 chip ?

i tried with a macbook intel and it worked, iam worried because i bought the macbook air just for that application...

Thank you


  • Hello @dada,

    Glypheo 1.36 was released just after the first Apple M1 machines shipped, and is an universal application optimized both for Intel and M1. But at this time, NDI library was not optimized for M1, so NDI is disabled when running Glypheo in Apple M1 one. This is the only limitation.

    Now, the version 1.37 uses the latest NDI library that is now optimized for Apple M1.

    In brief : please update.

    Best. Philippe

  • Hi

    Thank you for your answer i am gonna update.

    I launched the 1.36 with rosetta II and it worked.

    Thank you for your promptness as usual.

  • Hello i have a similar problem could you please help me.

    I ran Glypheo as NDI input in mac mini with M1 chip running Millumin without any problems from an older macbook.

    Now switching to a new macbook with big sur it no longer works.

    What could be the problem?

  • So i can also see the NDI input, as if everything is fine, but there is no panel output from Glypheo showing.

    From the older Macbook this works immediately.

    the macbook running glypheo (version 1.38) is running mac OS big sur11.5.2

    (the old macbook 2013 where everything works immediately is running Mojave)

    the mac mini running the Millumin project is running Big sur 11.5.1

  • We tried with yet another mac running Sierra, also no panel visible when the NDI input is put into a layer.

    So the NDI does show up in the inputs on the mac mini running Millumin.

    Only difference we can see is that the Mac that CAN show glypheo runs 1.36 the two macbooks where it does not show the panel run 1.38

    Thanks for the help!

  • Hello @ecco,

    Glypheo 1.38 is an universal application, optimized for both Intel and M1 machines. The NDI library is also optimized this way, so you should not have a problem.

    On your M1 machine, select then press CMD+I and activate "open using Rosetta". Restart Glypheo and tell me if it changes something.

    Best. Philippe

  • Hi Philippe thanks for your reply. Unfortunately this is no solution, both newer macbooks do not have an M1 chip (the 2 ones that we tried to run glypheo from) and do not run "Rosetta"

  • It is only the mini which runs the Millumin that is an M1 machine

    only from the older macbook (so in total there's 3 mac we tried running glypheo from)

    that has version 1.36 it works

    The other two macbooks are not M1

    they do not have rosetta

    the NDI source of glypheo shows up in millumin

    but there is no panel output


  • Hello @ecco,

    Sorry, but I am not sure to understand : you are running Glypheo and Millumin on 2 different Intel machines (not Apple M1), but the NDI does not work. Am I right ?

    First of all, be sure you are running latest version of Glypheo (1.38) and Millumin (3.18.o).

    Then, check that you can run Glypheo and Millumin on the same machine and use NDI.

    If ok, try with 2 separate machines for Glypheo and Millumin.

    Let us know the results. Philippe

Sign In or Register to comment.