Output on AJA IO 4K

edited August 2018 in MAIN
Hi there,

We came across the Millumin software a few days ago and would like to use it only for the playback of video content at an event.

Our Setting is:

MacPro (Late 2013) with an AJA IO 4K connected via Thunderbolt 2.
We can see the AJA NTV2 at the inputs, but is there any way to use the AJA as an output?

Thanks in advance

best regards

Dennis

Comments

  • Hello @Skyline,

    We just worked on it this week.
    This is something coming in the next beta of Millumin V2+. We sent you an intermediate version, so you could test it before.
    On our side, we tested this feature with a AJA TTap and a AJA IoXT.

    Best. Philippe

  • Hi Philippe,

    thank you very much for the quick response!

    At least we can see the IO 4K in the output popup with a variety of different output settings (resolutions & framerates).
    That works!

    Unfortunately there is a latency of approximately 15 frames and in addition the content looks very choppy, it seems like 12-15 fps to me (the result does not depend on which IO 4K output setting is selected – we tried several ones).

    I think, we'll have to test a little bit.
    If you have any idea, what will help here, please let us know.

    Thanks and best regards

    Dennis
  • Hello @Skyline,

    We're aware of such an issue, and we're currently investigating it with AJA engineers.
    For example : the format 720p60 is working with a very low latency on the TTap, but the format 720p50 got around 10-15 frames of latency. This is strange, because both format got the same treatment in Millumin.

    Anyway, we're waiting for the reply from AJA team.
    If you have some info about your testing, feel free to share here. Thank you.

    Best. Philippe
  • edited July 9
    Hi Phillipe,

    some time has passed. Are there any news concerning the collaboration between Millumin and AJA?
    Did you get a reply?

    Our setting is:
    MacPro (Late 2013) with an AJA IO 4K connected via Thunderbolt 2.  Software is Millumin3 3.11.q

    Unfortunately, we do not get a working 1080i50 signal from millumin.
    There still is a latency of approximately 15 frames and the content looks very choppy, it seems like 12-15 fps to me.
    Working with 1080i60 brings less choppiness and less latency, but is not perfect.

    But anyway this is no solution for us - for one particular event we do need an output in 1080i50 since we provide the millumin signal to the main video event mixer that requires 1080i50.

    Do you have any further suggestions or news concerning this issue?

    Thanks in advance!

    Best regards

    Dennis
  • Hello @Skyline,

    We ran tests on an AJA IO XT : 1080i50 and 1080i60 are correctly supported most of time, but in rare occasions, the device just doesn't work.
    It's strange and we're investigating the issue. This may be an issue fixed in recent AJA drivers/SDK.

    A few questions :
    - What is your version of AJA drivers ? 15.2.2 ?
    - Can you output 720p50 or 720p60 feeds correctly ?
    - Could you try to output 1080i50 or 1080i60 with latest Millumin beta version (3.12.l) ? What is the result ?

    Best. Philippe
  • Hello @Skyline,

    Apparently, the newest drivers from AJA are solving some issues. Did you try them ?
    We also upgraded Millumin to latest SDK (to match the latest drivers). We sent you an intermediate version via email, let us know the results.

    Best. Philippe
  • edited September 3
    Hello Philippe,

    thanks in advance! Unfortunately, we didn't receive an email with the intermediate version.
    But we downloaded and tested Millumin 3.12.o (beta), please see the results below.

    Our hardware setup:
    MacPro Late 2013 with macOS
    10.14.6 (Mojave)
    AJA IO 4K (Firmware 4K 2019/05/22), AJA drivers 15.2.3.2

    Test results for Millumin 3.11.q

    1080i50 / 1080p25 / 1080p50 (our relevant formats):
    - latency of approximately 500-600ms
    - content looks very choppy


    720p50
    - a little less latency and choppiness, but still useless

    720p60
    - not choppy, nearly no latency.

    Test results for Millumin 3.12.o (beta)

    1080i50 / 1080p25 / 1080p50 (our relevant formats):
    - still a latency of approximately 500-600ms
    - content does not look choppy!

    So, with the 3.12 beta, the result looks just fine!
    But the latency is still there in all 1080 output formats and 720p50.
    No problems in 720p60.

    Do you have any further suggestions?

    Thanks and best regards,

    Dennis
  • Hello @Skyline,

    The comment saying we sent you an intermediate version was last year (august 2018, not august 2019). It was before release of Millumin V3 !

    About the latest version of Millumin V3 (beta 3.12.o) : I'm glad it's fine now.
    I also observed a higher latency in 720p50 and 1080p50 format in Resolume. For now, I'm sorry but I don't have an explanation, but I asked AJA engineers about it.
    For info, you didn't test the 1080p60 format, but it had a small latency in our tests (like the 720p60 format).

    Best. Philippe
Sign In or Register to comment.