Arduino / Auto-program issue [solved]

edited December 2017 in MAIN
I can get the "auto-program" to work:

- In millumin, I've setup My arduino Uno, serial is ok/green, active is ticked.
- a servomotor is plugged on D8 (if I upload a simple servomotor program to the arduino, the servomotor is spinning ok, so no problem on this side)
- I hit "auto-program" : key "D8", Type "Servo", if I hit "test" the RX LED is flashing but the servomotor doesn't move.

I click Upload "Installing PlatformIO" windows appears. Then Terminal, password... everything seems ok.
but if I click Upload again, the "Installing PlatformIO" windows appears again. It's a loop !?

If I hit test, my servomotor doesn't spin (but RX LED is flashing).
If I create data keyframe my servomotor doesn't spin (but RX LED is flashing).

I've updated Xcode to the last version (it was 7.2 when I've tried to Install PlatformIO the first time)
So, I don't know what else to do.
Help please ;)


  • Oupss
    I can't get the "auto-program" to work
  • Ok, got it working :D
    - Uninstalled Xcode with cleanmymac
    - relaunched the "upload" script.

    everything is ok ;)
  • Hi I have the same problem, tried your solution and it did'nt work for me. What can I do ?

  • Hello @mentalo,

    A few questions :

    • Does your Arduino work with ?
    • What is your version of Millumin ? 3.18.p ?
    • What is your version of macOS ? 10.15.7 ?

    Best. Philippe

  • Hi, yes it works fine with the ide. I use the last version of millumin. My Os is big sur.

    Thanks !

  • Hello @mentalo,

    Please open a Terminal and type the following commands :

    • brew uninstall platformio
    • brew install platformio

    Take a screenshot of the result when it's finished (it could take some time). Thank you.

    Best. Philippe

  • here is what i get.. it seems ok to me !

  • Hello @mentalo,

    Thank you for the info, I think I have found the problem.

    Could you type in your Terminal the command echo $SHELL : what is the result ? /bin/zsh or /bin/bash ?

    Thank you. Philippe

  • Hello @mentalo,

    Do you still have the issue with Millumin 4.12.h ? (we are preparing an update for Millumin V3 as well)

    The issue came from a change in how the Terminal is handling commands since macOS Big Sur.

    Best. Philippe

  • Hi Milluminers,

    I'm having condition when I run the auto program, it ask me to install the Platform IO, after I've install, it also pops the same result I'm using Millumin V3.18s on Mac mini M2Pro with MacOs 13.4.1

    Is there any chance to fix?

    best regards


  • Hello @ivanlee419,

    Do you have the same problem with Millumin V4 ?

    This issue has been fixed for Millumin V4, and next update of Millumin V3 will have the same fix.

    Best. Philippe

  • Hi Philippe,

    nope, I didn't ready to upgrade to V4 according to economy. Any idea when will the new update comes up for V3?



  • Hello @ivanlee419,

    Sorry, no hard date as we are focused on Millumin V4.

    However, you can use the trial version of Millumin V4 to program your Arduino on macOS Ventura, then use Millumin V3 as usual.

    Best. Philippe

Sign In or Register to comment.